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Chapter 1. Setting up the environment

The goal of this chapter of the tutorial is to install (or check that you already have installed) a
minimally needed set of software to build a Cayenne application.

1.1. Install Java

Obviously, JDK has to be installed. Cayenne 3.1 requires JDK 1.5 or newer.

1.2. Install Eclipse IDE and the Maven Plugin

Download Eclipse. This tutorial is based on the Galileo package (Eclipse 3.5), JEE edition, still it
should work with any recent vanilla Eclipse distribution.

After downloading Eclipse, unpack it somewhere in the filesystem, and start it. The only plugin that
you need for the tutorial is m2eclipse. To install it, in Eclipse go to "Help > Install New Software",
then click on "Add.." to add a new download site, and enter "Maven" in the "Name" field, and
"http://m2eclipse.sonatype.org/sites/m2e" in the "Location" field. You may install any of the optional
components that you think you need, but for this tutorial we only select a few basic components as
shown on the following screenshot:

ann Install
Available Software

Check the items that you wish to install. \f):
Work with: | http:/ fm2eclipse.sonatype.org/sites/m2e :] Add...

Find more software by working with the "Available Software Sites” preferences.

" type filter text

Name Version
E ¥ (00 Maven Integration for Eclipse
E Q,'InMaven Integration for Eclipse (Required) 0.12.1.20110112-1712
( selectall ) ( DeselectAll ) L item selected
Details
E Show only the latest versions of available software [ Hide items that are already installed
E Group items by category What is already installed?

E Contact all update sites during install to find required software

® < Back E Next = ﬂ [ Cancel :I Finish




From here follow the Eclipse dialog instructions to finish the installation.



Chapter 2. Learning mapping basics

2.1. Starting a project

The goal of this chapter is to create a new Java project in Intelli] IDEA containing a basic Cayenne
mapping. It presents an introduction to CayenneModeler GUI tool, showing how to create the initial
mapping objects: DataDomain, DataNode, DataMap.

Create a new Project in Eclipse

In Eclipse select "File > New > Other..." and then "Maven > Maven Project". Click "Next". On the
following screen check "Create a simple project" checkbox and click "Next" again. In the dialog
shown on the screenshot below, fill the "Group Id" and "Artifact Id" fields and click "Finish".

800 New Maven Project

MNew Maven project e g
Configure project ﬁ
Artifact
Group Id: org.example.cayenne ﬂ
Artifact 1d:  tutorial '1
Version: 0.0.1-SNAPSHOT -]
Packaging:  jar ﬂ
Mame: ﬂ
Description:

Parent Project

Group Id: j
Artifact Id: -]
Version: j |: Browse... ) Clear
b Advanced
@ |: < Back j |: Mext = ) |: Cancel ) E—ﬂnhh—a
e

Now you should have a new empty project in the Eclipse workspace. Check that the project Java
compiler settings are correct. Rightclick on the "tutorial" project, select "Properties > Java Compiler"
and ensure that "Compiler compliance level" is at least "1.5" (some versions of Maven plugin seem
to be setting it to 1.4 by default).



Download and Start CayenneModeler

Although later in this tutorial we’ll be using Maven to include Cayenne runtime jars in the project,
you’ll still need to download Cayenne to get access to the CayenneModeler tool.

0 If you are really into Maven, you can start CayenneModeler from Maven too. We’ll
do it in a more traditional way here.

Download the latest release. Unpack the distribution somewhere in the file system and start

CayenneModeler, following platform-specific instructions. On most platforms it is done simply by
doubleclicking the Modeler icon. The welcome screen of the Modeler looks like this:

Search:

. 3
I

CAYENNE

P Recent Projects:

Mew Project Open Project

Create a New Mapping Project in CayenneModeler

Click on the New Project button on Welcome screen. A new mapping project will appear that
contains a single DataDomain. The meaning of a DataDomain is explained elsewhere in the User
Guide. For now it is sufficient to understand that DataDomain is the root of your mapping project.

Create a DataNode

The next project object you will create is a DataNode. DataNode is a descriptor of a single database
your application will connect to. Cayenne mapping project can use more than one database, but for
now, we’ll only use one. With "project” selected on the left, click on Create DataNode button = on
the toolbar (or select Project > Create DataNode from the menu).



A new DataNode is displayed. Now you need to specify JDBC connection parameters. For an in-
memory Derby database you can enter the following settings:

* JDBC Driver: org.apache.derby.jdbc.EmbeddedDriver
* DB URL: jdbc:derby:memory:testdb;create=true

We are creating an in-memory database here. So when you stop your application,

0 all the data will be lost. In most real-life cases you’ll be connecting to a database
that actually persists its data on disk, but an in-memory DB will do for the simple
tutorial.
Also you will need to change "Schema Update Strategy". Select

org.apache.cayenne.access.dbsync.CreateIfNoSchemaStrategy from the dropdown, so that Cayenne
creates a new schema on Derby based on the ORM mapping when the application starts.

fan6n * - CayenneModeler - [New]
|[Bl=Ta) (=] [</ma [@]e] [6]s] @@ @] (][] Search:
& project E-Main | Adapter  Password Encoder 1
o

DataMode Configuration

DataMode Mame: datanode

Schema Update Strategy: apache.cayenne.access.dbsync.SkipSchemaUpdateStrategy j
You can enter custom class implementing SchemalpdateStrategy

Local DataSource (opt.): [ Select DataSource for Local Work... F%'i @

DataSource Factory: ayenne.configuration.server.XMLPoolingDataSourceFactory ﬂ

JDBC Configuration

JDBC Driver: org.apache.derby.jdbc.EmbeddedDriver

DB URL: jdbc:derby:memory:testdb;create=true

Username:

Password:
Min Connections: 1

Max Connections: 1

Sync with Local

Create a DataMap

Now you will create a DataMap. DataMap is an object that holds all the mapping information. To
create it, click on "Create DataMap" button (or select a corresponding menu item). Note that the
newly created DataMap is automatically linked to the DataNode that you created in the previous
step. If there is more than one DataNode, you may need to link a DataMap to the correct node
manually. In other words a DataMap within DataDomain must point to a database described by the



map.

You can leave all the DataMap defaults unchanged except for one - "Java Package". Enter
"org.example.cayenne.persistent”. This name will later be used for all persistent classes.

8000 * _ Cayenn deler - [New]
([EEEEERHEIET WEOHE Y E R E RN E B Search.
8 proeg FoataMas)
Yo —
> & datanode DataMap Configuration

DataMap Name: datamap
File: (no file)
DataNode: [ {3 datanode I-a-q

Quote SQL Identifiers: [ |

—

Entity Defaults

DB Schema: [ Update... )

Java Package: [org.example.cayenne.persistent ] ( Update... )

Custom Superclass: [ Update... )

Optimistic Locking: [

Client Class Defaults

Allow Client Entities: [

Client Java Package: ( Update... )

S

Custom Superclass: ( Update... )

Save the Project

Before you proceed with the actual mapping, let’s save the project. Click on "Save" button in the
toolbar and navigate to the "tutorial" Eclipse project folder that was created earlier in this section
and its "src/main/resources"” subfolder and save the project there. Now go back to Eclipse, right click
on "tutorial" project and select "Refresh", you will see three Cayenne XML files.
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‘F:"Lfﬂ-tuturial
b 2 src/main/java
|| cayenne-project.xml
|%] datamap.map.xmil
b B sreftest/java
b 2 src/test/resources
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'ﬂﬁ Maven Dependencies
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b (= target
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Note that the location of the XML files is not coincidental. Cayenne runtime looks for cayenne-*.xml
file in the application CLASSPATH and src/main/resources folder should already be a "class folder" in
Eclipse for our project (and is also a standard location that Maven would copy to a jar file, if we
were using Maven from command-line).

2.2. Getting started with Object Relational Mapping
(ORM)

The goal of this section is to learn how to create a simple Object-Relational model with
CayenneModeler. We will create a complete ORM model for the following database schema:

| ARTIST v
CIDINT

> NAME VARCHAR(200)

<> DATE_OF_BIRTH DATE

>
+
1
A
—| PAINTING v
CIDVINT
> NAME VARCHAR(200)
2 ARTIST_ID INT
2 GALLERY _ID INT
>
T
¥
| GALLERY v
D INT
> NAME VARCHAR(200)
>



Very often you’d have an existing database already, and it can be quickly imported
0 in Cayenne via "Tools > Reengineer Database Schema". This will save you lots of

time compared to manual mapping. However understanding how to create the

mapping by hand is important, so we are showing the "manual" approach below.

Mapping Database Tables and Columns

Lets go back to CayenneModeler where we have the newly created project open and start by adding
the ARTIST table. Database tables are called DbEntities in Cayenne mapping (those can be actual
tables or database views).

Select "datamap"” on the left-hand side project tree and click "Create DbEntity" button & (or use
"Project > Create DbEntity" menu). A new DbEntity is created. In "DbEntity Name" field enter
"ARTIST". Then click on "Create Attribute" button % on the entity toolbar. This action changes the
view to the "Attribute" tab and adds a new attribute (attribute means a "table column" in this case)
called "untitledAttr". Let’s rename it to ID, make it an INTEGER and make it a PK:

anNne * - CayenneModeler - /Users/dzmitry/tutorial/src/main/resources/cayenne-project.xml
|Cl=Tal (#] [#[=lal [@]9] [6]a] [E@E [ele[a] [¢]2] Search:
& projeat [ Entity - Attributes | Relationships |

v o datamap o .
o | %% [« [£[E]a

» [ datanode Name ¥ Type PK Mandatory [Max Length|  Scale

b [NTEGER

Similarly add NAME VARCHAR(200) and DATE_OF_BIRTH DATE attributes. After that repeat this
procedure for PAINTING and GALLERY entities to match DB schema shown above.

Don’t forget to save your project periodically to avoid losing your work. You will
also have to refresh the project in Eclipse after every CayenneModeler save, as
Eclipse is by default unaware of any changes made in the Modeler.

Mapping Database Relationships

Now we need to specify relationships between ARTIST, PAINTING and GALLERY tables. Start by
creating a one-to-many ARTIST/PAINTING relationship:
 Select the ARTIST DbEntity on the left and click on the "Properties" tab.

* Click on "Create Relationship” button on the entity toolbar “ - a relationship called
"untitledRel" is created.



* Choose the "Target" to be "Painting".

+ Click on the "Database Mapping" button [4 - relationship configuration dialog is presented. Here
you can assign a name to the relationship and also its complimentary reverse relationship. This
name can be anything (this is really a symbolic name of the database referential constraint), but
it is recommended to use a valid Java identifier, as this will save some typing later. We’ll call the
relationship "paintings" and reverse relationship "artist".

* Click on "Add" button on the right to add a join
* Select "ID" column for the "Source" and "ARTIST_ID" column for the target.

* Relationship information should now look like this:

[ = BN ) DbRelationship Info: ARTIST to PAINTING

DbRelationship Information

Relationship: | paintings

Reverse Relationship [anist| ]

Joins

Source ¥ | Target
ID ARTIST_ID

Add

( Done ;'l ( Cancel )

* Click "Done" to confirm the changes and close the dialog.

* Two complimentary relationships have been created - from ARTIST to PAINTING and back. Still
you may have noticed one thing is missing - "paintings" relationship should be to-many, but "To
Many" checkbox is not checked. Let’s change that - check the checkbox for "paintings"
relationship, and then click on PAINTING DbEntity, and uncheck "artist" relationship "To Many"
to make the reverse relationship "to-one" as it should be.

* Repeat the steps above to create a many-to-one relationship from PAINTING to GALLERY, calling
the relationships pair "gallery" and "paintings".

Mapping Java Classes

Now that the database schema mapping is complete, CayenneModeler can create mappings of Java
classes (aka "ObjEntities") by deriving everything from DbEntities. At present there is no way to do
it for the entire DataMap in one click, so we’ll do it for each table individually.
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« Select "ARTIST" DbEntity and click on "Create ObjEntity" button () either on the entity toolbar
or on the main toolbar. An ObjEntity called "Artist" is created with a Java class field set to
"org.example.cayenne.persistent.Artist". The modeler transformed the database names to the
Java-friendly names (e.g., if you click on the "Attributes" tab, you’ll see that "DATE_OF_BIRTH"
column was converted to "dateOfBirth" Java class attribute).

» Select "GALLERY" DbEntity and click on "Create ObjEntity" button again - you’ll see a "Gallery"
ObjEntity created.

* Finally, do the same thing for "PAINTING".

Now you need to synchronize relationships. Artist and Gallery entities were created when there
was no related "Painting" entity, so their relationships were not set.

* Click on the "Artist" ObjEntity. Now click on "Sync ObjEntity with DbEntity" button on the
toolbar t# - you will see the "paintings” relationship appear.
* Do the same for the "Gallery" entity.

Unless you want to customize the Java class and property names (which you can do easily) the
mapping is complete.

2.3. Creating Java Classes

Here we’ll generate the Java classes from the model that was created in the previous section.
CayenneModeler can be used to also generate the database schema, but since we specified
“CreatelfNoSchemaStrategy” earlier when we created a DataNode, we’ll skip the database schema
step. Still be aware that you can do it if you need to via "Tools > Create Database Schema".

Creating Java Classes

» Select "Tools > Generate Classes" menu.
» For "Type" select "Standard Persistent Objects", if it is not already selected.

* For the "Output Directory"” select “src/main/java” folder under your IDEA project folder (this is a
"peer"” location to the cayenne-*.xml location we selected before).

* Click on "Classes" tab and check the "Check All Classes" checkbox (unless it is already checked
and reads "Uncheck all Classes").

¢ Click "Generate"

Now go back to Eclipse, right click on "tutorial" project and select "Refresh" - you should see pairs of
classes generated for each mapped entity. You probably also see that there’s a bunch of red
squiggles next to the newly generated Java classes in Eclipse. This is because our project does not
include Cayenne as a Maven dependency yet. Let’s fix it now by adding "cayenne-server" artifact in
the bottom of the pom.xml file. The resulting POM should look like this:
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<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi=
"http://www.w3.0rg/2001/XMLSchema-instance"
xsi:schemalocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupld>org.example.cayenne</groupId>
<artifactId>tutorial</artifactId>
<version>0.0.1-SNAPSHOT</version>

<dependencies>
<dependency>
<groupld>org.apache.cayenne</groupld>
<artifactId>cayenne-server</artifactId>
<!-- Here specify the version of Cayenne you are actually using -->
<version>3.1.3</version>
</dependency>
</dependencies>
</project>

Your computer must be connected to the internet. Once you save the pom.xml, Eclipse will
download the needed Cayenne jar file and add it to the project build path. As a result, all the errors
should disappear.

T = 5
[ Project Explorer 53 = <}==§> ~ a W _Gallery.java 1 [J| Datamap.java 1

YE,;—‘,J-tutorial package org.exomple.cayenne.persistent.auto;
¥ (Hsrc/main/java
Yﬁ org.example.cayenne.persistent
P@ Artist.java

@ import java.util.Date;[]

=Ll
> mDatamap.Ja\ra * (lass _Artist waos generoted by Cavenne.
b@ﬂallew.ja\ra * T+ is probably a good idea to aveid changing -
¥ 1J] Painting.java * cince it may be overwritten next time code is
Yl._ﬁ}org.example.ca!_.renne.persistent.auto * Tf wou need to make any customizations, pleas
> 1] _Artist.java */
b [J] _Datamap.java 4 public abstract class _Artist extends CayenneDats

> ] Gallery.java

P@ Paintingjava public static final String DATE_OF_BIRTH_PRO

public static final String NAME_PROPERTY = "i

¥ [ sre/main/resources public static final String PAINTINGS_PROPERT
|X| cayenne-project.xml
|%] datamap.map.xmil public static final String ID_PK_COLUMN = "II
b [ src/ftest/java
b [ src/test/resources = public wvoid setDatel0fBirth{Dote dateOfBirth)
b = JRE System Library [J25E-1.5] writeProperty("daote0fBirth", dateOfBirth
w . : 1
v
-f,ﬁhlmn Dependencies . r - = public Date getDateOfBirth() {
ey il et atereadpropertyCdeteoici
— - - ¢ g - d
[ 2 @i commons-logging-1.1.jar - /Users/dzmil
> @ velocity-1.6.3.jar - /Users/dzmitry/.m2/r = public woid setMame(String name} {
b (i commons-lang-2.4.jar - [Users/dzmitry/ writeProperty("nome", namel;
> @ oro-2.0.8.jar - fUsers/dzmitry/.m2/repo: I3 i
b G src = public String getName() {
Pé&target return (StringlreadProperty("name");
") pom.xml '
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Now let’s check the entity class pairs. Each one is made of a superclass (e.g. Artist) and a subclass
(e.g. Artist). You should not modify the superclasses whose names start with "_" (underscore), as
they will be replaced on subsequent generator runs. Instead all custom logic should be placed in the
subclasses in "org.example.cayenne.persistent” package - those will never be overwritten by the
class generator.

Class Generation Hint

Often you’d start by generating classes from the Modeler, but at the later stages of

Q the project the generation is usually automated either via Ant cgen task or Maven
cgen mojo. All three methods are interchangeable, however Ant and Maven
methods would ensure that you never forget to regenerate classes on mapping
changes, as they are integrated into the build cycle.
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Chapter 3. Learning Cayenne API

3.1. Getting started with ObjectContext

In this section we’ll write a simple main class to run our application, and get a brief introduction to
Cayenne ObjectContext.

Creating the Main Class

* n Eclipse create a new class called "Main" in the "org.example.cayenne" package.

e Create a standard "main" method to make it a runnable class:

package org.example.cayenne;
public class Main {

public static void main(String[] args) {
}

* The first thing you need to be able to access the database is to create a ServerRuntime object
(which is essentially a wrapper around Cayenne stack) and use it to obtain an instance of an
ObjectContext.

package org.example.cayenne;

import org.apache.cayenne.ObjectContext;
import org.apache.cayenne.configuration.server.ServerRuntime;

public class Main {

public static void main(String[] args) {
ServerRuntime cayenneRuntime = new ServerRuntime(
"cayenne-project.xml");
ObjectContext context = cayenneRuntime.getContext();

ObjectContext is an isolated "session" in Cayenne that provides all needed API to work with data.
ObjectContext has methods to execute queries and manage persistent objects. We’ll discuss them in
the following sections. When the first ObjectContext is created in the application, Cayenne loads
XML mapping files and creates a shared access stack that is later reused by other ObjectContexts.

Running Application

Let’s check what happens when you run the application. But before we do that we need to add
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another dependency to the pom.xml - Apache Derby, our embedded database engine. The following
piece of XML needs to be added to the <dependencies>::-</dependencies> section, where we already
have Cayenne jars:

<dependency>
<groupId>org.apache.derby</groupIld>
<artifactId>derby</artifactId>
<version>10.8.1.2</version>
</dependency>

Now we are ready to run. Right click the "Main" class in Eclipse and select "Run As > Java
Application”. In the console you’ll see output similar to this, indicating that Cayenne stack has been
started: In the console you’ll see output similar to this, indicating that Cayenne stack has been
started:

INFO: Loading XML confiquration resource from file:cayenne-project.xml
INFO: loading user name and password.
INFO: Created connection pool: jdbc:derby:memory:testdb;create=true
Driver class: org.apache.derby.jdbc.EmbeddedDriver
Min. connections in the pool: 1
Max. connections in the pool: 1

How to Configure Cayenne Logging

Follow the instructions in the logging chapter to tweak verbosity of the logging output.

3.2. Getting started with persistent objects

In this chapter we’ll learn about persistent objects, how to customize them and how to create and
save them in DB.

Inspecting and Customizing Persistent Objects

Persistent classes in Cayenne implement a DataObject interface. If you inspect any of the classes
generated earlier in this tutorial (e.g. org.example.cayenne.persistent.Artist), you’ll see that it
extends a class with the name that starts with underscore
(org.example.cayenne.persistent.auto._Artist), which in turn extends from
org.apache.cayenne.CayenneDataObject. Splitting each persistent class into user-customizable
subclass (Xyz) and a generated superclass (_Xyz) is a useful technique to avoid overwriting the
custom code when refreshing classes from the mapping model.

Let’s for instance add a utility method to the Artist class that sets Artist date of birth, taking a string
argument for the date. It will be preserved even if the model changes later:
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public class Artist extends _Artist {

static final String DEFAULT_DATE_FORMAT = "yyyyMMdd";

/**

* Sets date of birth using a string in format yyyyMMdd.
*
/
public void setDateOfBirthString(String yearMonthDay) {
if (yearMonthDay == null) {
setDate0fBirth(null);
} else {

Date date;
try {
date = new SimpleDateFormat(DEFAULT_DATE_FORMAT)
.parse(yearMonthDay);
} catch (ParseException e) {
throw new IllegalArgumentException(
"A date argument must be in format
+ DEFAULT_DATE_FORMAT + "': " + yearMonthDay);

}

setDate0fBirth(date);

Create New Objects

Now we’ll create a bunch of objects and save them to the database. An object is created and
registered with ObjectContext using “newObject” method. Objects must be registered with
DataContext to be persisted and to allow setting relationships with other objects. Add this code to the
"main" method of the Main class:

Artist picasso = context.newObject(Artist.class);
picasso.setName("Pablo Picasso");
picasso.setDate0fBirthString("18811025");

Note that at this point "picasso” object is only stored in memory and is not saved in the database.
Let’s continue by adding a Metropolitan Museum “Gallery” object and a few Picasso "Paintings":
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Gallery metropolitan = context.newObject(Gallery.class);
metropolitan.setName("Metropolitan Museum of Art");

Painting girl = context.newObject(Painting.class);
girl.setName("Girl Reading at a Table");

Painting stein = context.newObject(Painting.class);
stein.setName("Gertrude Stein");

Now we can link the objects together, establishing relationships. Note that in each case below
relationships are automatically established in both directions (e.g. picasso.addToPaintings(girl)
has exactly the same effect as girl.setToArtist(picasso)).

picasso.addToPaintings(girl);
picasso.addToPaintings(stein);

girl.setGallery(metropolitan);
stein.setGallery(metropolitan);

Now lets save all five new objects, in a single method call:

context.commitChanges();

Now you can run the application again as described in the previous chapter. The new output will
show a few actual DB operations:

17



org.apache.cayenne.configuration.XMLDataChannelDescriptorLoader load
INFO: Loading XML configuration resource from file:cayenne-project.xml

INFO: Opening connection: jdbc:derby:memory:testdb;create=true

Login: null

Password: *******
INFO: +++ Connecting: SUCCESS.
INFO: Detected and installed adapter: org.apache.cayenne.dba.derby.DerbyAdapter
INFO: --- transaction started.
INFO: No schema detected, will create mapped tables
INFO: CREATE TABLE GALLERY (ID INTEGER NOT NULL, NAME VARCHAR (200), PRIMARY KEY (ID))
INFO: CREATE TABLE ARTIST (DATE_OF_BIRTH DATE, ID INTEGER NOT NULL, NAME VARCHAR
(200), PRIMARY KEY (ID))
INFO: CREATE TABLE PAINTING (ARTIST_ID INTEGER, GALLERY_ID INTEGER, ID INTEGER NOT
NULL,

NAME VARCHAR (200), PRIMARY KEY (ID))
INFO: ALTER TABLE PAINTING ADD FOREIGN KEY (ARTIST_ID) REFERENCES ARTIST (ID)
INFO: ALTER TABLE PAINTING ADD FOREIGN KEY (GALLERY_ID) REFERENCES GALLERY (ID)
INFO: CREATE TABLE AUTO_PK_SUPPORT (
TABLE_NAME CHAR(100) NOT NULL, NEXT_ID BIGINT NOT NULL, PRIMARY

KEY(TABLE_NAME))
INFO: DELETE FROM AUTO_PK_SUPPORT WHERE TABLE_NAME IN ('ARTIST', 'GALLERY',
"PAINTING")
INFO: INSERT INTO AUTO_PK_SUPPORT (TABLE_NAME, NEXT_ID) VALUES ('ARTIST', 200)
INFO: INSERT INTO AUTO_PK_SUPPORT (TABLE_NAME, NEXT_ID) VALUES ('GALLERY', 200)
INFO: INSERT INTO AUTO_PK_SUPPORT (TABLE_NAME, NEXT_ID) VALUES ('PAINTING', 200)
INFO: SELECT NEXT_ID FROM AUTO_PK_SUPPORT WHERE TABLE_NAME = ? FOR UPDATE [bind:
1:"ARTIST']
INFO: SELECT NEXT_ID FROM AUTO_PK_SUPPORT WHERE TABLE_NAME
1:"GALLERY'"]
INFO: SELECT NEXT_ID FROM AUTO_PK_SUPPORT WHERE TABLE_NAME
1:"PAINTING']
INFO: INSERT INTO GALLERY (ID, NAME) VALUES (7, ?7)
INFO: [batch bind: 1->ID:200, 2->NAME: 'Metropolitan Museum of Art']
INFO: === updated 1 row.
INFO: INSERT INTO ARTIST (DATE_OF_BIRTH, ID, NAME) VALUES (?, ?, ?7)
INFO: [batch bind: 1->DATE_OF_BIRTH:'1881-10-25 00:00:00.0"', 2->ID:200, 3->NAME:'Pablo
Picasso']
INFO: === updated 1 row.
INFO: INSERT INTO PAINTING (ARTIST_ID, GALLERY_ID, ID, NAME) VALUES (?, 7, ?, ?7)
INFO: [batch bind: 1->ARTIST_ID:200, 2->GALLERY_ID:200, 3->ID:200, 4->NAME:'Gertrude
Stein']
INFO: [batch bind: 1->ARTIST_ID:200, 2->GALLERY_ID:200, 3->ID:201, 4->NAME:'Girl
Reading at a Table']
INFO: === updated 2 rows.
INFO: +++ transaction committed.

? FOR UPDATE [bind:

? FOR UPDATE [bind:

So first Cayenne creates the needed tables (remember, we used “CreateIfNoSchemaStrategy”). Then
it runs a number of inserts, generating primary keys on the fly. Not bad for just a few lines of code.
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3.3. Selecting Objects

This chapter shows how to select objects from the database using ObjectSelect query.

Introducing ObjectSelect

It was shown before how to persist new objects. Cayenne queries are used to access already saved
objects. The primary query type used for selecting objects is ObjectSelect. It can be mapped in
CayenneModeler or created via the API. We’ll use the latter approach in this section. We don’t have
too much data in the database yet, but we can still demonstrate the main principles below.

* Select all paintings (the code, and the log output it generates):

SelectQuery select1 = new SelectQuery(Painting.class);
List paintings1 = context.performQuery(select);

INFO: SELECT t@.GALLERY _ID, t@.ARTIST_ID, t@.NAME, t@.ID FROM PAINTING t@
INFO: === returned 2 rows. - took 18 ms.

 Select paintings that start with “gi”, ignoring case:

Expression qualifier2 = ExpressionFactory.likeIgnoreCaseExp(
Painting.NAME_PROPERTY,
llg_i%ll);
SelectQuery select2 = new SelectQuery(Painting.class, qualifier2);
List paintings2 = context.performQuery(select?2);

INFO: SELECT t@.GALLERY_ID, t@.NAME, t@.ARTIST_ID, t@.ID FROM PAINTING t@ WHERE
UPPER(t@.NAME) LIKE UPPER(?)

[bind: 1->NAME:'gi%'] - prepared in 6 ms.
INFO: === returned 1 row. - took 18 ms.

 Select all paintings done by artists who were born more than a 100 years ago (demonstrating
using Expression.fromString(..) instead of ExpressionFactory):

Calendar c = new GregorianCalendar();
c.set(c.get(Calendar.YEAR) - 100, @, 1, 0, 0, 0);

Expression qualifier3 = Expression.fromString("artist.date0fBirth < $date");
qualifier3 = qualifier3.expWithParameters(Collections.singletonMap("date",
c.getTime()));

SelectQuery select3 = new SelectQuery(Painting.class, qualifier3);

List paintings3 = context.performQuery(select3);

19



INFO: SELECT tO.GALLERY_ID, t@.NAME, t@.ARTIST_ID, t@.ID FROM PAINTING t@ JOIN ARTIST

t1 ON (t@.ARTIST_ID = t1.1ID)
WHERE t1.DATE_OF_BIRTH < ? [bind: 1->DATE_OF_BIRTH:'1911-01-01 00:00:00.493'] -

prepared in 7 ms.
INFO: === returned 2 rows. - took 25 ms.

3.4. Deleting Objects

This chapter explains how to model relationship delete rules and how to delete individual objects
as well as sets of objects. Also demonstrated the use of Cayenne class to run a query.

Setting Up Delete Rules

Before we discuss the API for object deletion, lets go back to CayenneModeler and set up some
delete rules. Doing this is optional but will simplify correct handling of the objects related to deleted
objects.

In the Modeler go to "Artist" ObjEntity, "Relationships” tab and select "Cascade" for the "paintings"
relationship delete rule:

(o N Né)] * _ CayenneModeler - /Users/dzmitry/tutorial /src/main/resources /cayenne-praject.xmil
|Elem ] ZElal (¢ 6] @@ [c[eln] =] Search
g projeat [ Entity = Attributes - Relationships | Callbacks | Listeners 1

v o datamap

omm | ISIEO)[»][<[Eln

® Gallery Name 7 Target Semantics Delete Rule | Used for Locking
[ ARTIST

(] GALLERY

[E] PAINTING |,

» @ datanode

Repeat this step for other relationships:

» For Gallery set "paintings" relationship to be "Nullify", as a painting can exist without being
displayed in a gallery.

» For Painting set both relationships rules to "Nullify".

Now save the mapping.

Deleting Objects

While deleting objects is possible via SQL, qualifying a delete on one or more IDs, a more common
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way in Cayenne (or ORM in general) is to get a hold of the object first, and then delete it via the
context. Let’s use utility class Cayenne to find an artist:

Expression qualifier = ExpressionFactory.matchExp(Artist.NAME_PROPERTY, "Pablo
Picasso");

SelectQuery select = new SelectQuery(Artist.class, qualifier);

Artist picasso = (Artist) Cayenne.objectForQuery(context, select);

Now let’s delete the artist:

if (picasso != null) {
context.deleteObject(picasso);
context.commitChanges();

Since we set up "Cascade" delete rule for the Artist.paintings relationships, Cayenne will
automatically delete all paintings of this artist. So when your run the app you’ll see this output:

INFO: SELECT t@.DATE_OF_BIRTH, t@.NAME, t@.ID FROM ARTIST t@
WHERE t@.NAME = ? [bind: 1->NAME:'Pablo Picasso'] - prepared in 6 ms.

INFO: === returned 1 row. - took 18 ms.
INFO: +++ transaction committed.
INFO: --- transaction started.

INFO: DELETE FROM PAINTING WHERE ID = ?
INFO: [batch bind: 1->ID:200]

INFO: [batch bind: 1->ID:201]

INFO: === updated 2 rows.

INFO: DELETE FROM ARTIST WHERE ID = ?
INFO: [batch bind: 1->ID:200]

INFO: === updated 1 row.

INFO: +++ transaction committed.
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Chapter 4. Converting to Web Application

This chapter shows how to work with Cayenne in a web application.

4.1. Converting Tutorial to a Web Application

The web part of the web application tutorial is done in JSP, which is the least common denominator
of the Java web technologies, and is intentionally simplistic from the UI perspective, to concentrate
on Cayenne integration aspect, rather than the interface. A typical Cayenne web application works
like this:

* Cayenne configuration is loaded when an application context is started, using a special servlet
filter.

» User requests are intercepted by the filter, and the DataContext is bound to the request thread,
so the application can access it easily from anywhere.

* The same DataContext instance is reused within a single user session; different sessions use
different DataContexts (and therefore different sets of objects). The context can be scoped
differently depending on the app specifics. For the tutorial we’ll be using a session-scoped
context.

So let’s convert the tutorial that we created to a web application:

* In Eclipse under "tutorial” project folder create a new folder "src/main/webapp/WEB-INF".

* Under WEB-INF create a new file web.xml (a standard web app descriptor):
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web.xml

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE web-app
PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN"
"http://java.sun.com/dtd/web-app_2_3.dtd">
<web-app>
<display-name>Cayenne Tutorial</display-name>

<!-- This filter bootstraps ServerRuntime and then provides each request thread
with a session-bound DataContext. Note that the name of the filter is
important,
as 1t points it to the right named configuration file.
-->
<filter>
<filter-name>cayenne-project</filter-name>
<filter-class>org.apache.cayenne.configuration.web.CayenneFilter</filter-
class>
</filter>
<filter-mapping>
<filter-name>cayenne-project</filter-name>
<url-pattern>/*</url-pattern>
</filter-mapping>
<welcome-file-list>
<welcome-file>index.jsp</welcome-file>
</welcome-file-list>
</web-app>

* Create the artist browser page src/main/webapp/index. jsp file with the following contents:
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webapp/index.jsp

<%@ page language="java" contentType="text/html" %>
<%@ page import="org.example.cayenne.persistent.*" %>
<%@ page import="org.apache.cayenne.*" %>
<%@ page import="org.apache.cayenne.query.*" %>
<%@ page import="org.apache.cayenne.exp.*" %>
<%@ page import="java.util.*" %>
<%
SelectQuery query = new SelectQuery(Artist.class);
query.addOrdering(Artist.NAME_PROPERTY, SortOrder.ASCENDING);
ObjectContext context = BaseContext.getThreadObjectContext();
List<Artist> artists = context.performQuery(query);
%>
<html>
<head>
<title>Main</title>
</head>
<body>
<h2>Artists:</h2>
<% if(artists.isEmpty()) {%>
<p>No artists found</p>
<% } else {
for(Artist a : artists) {
%>
<p><a href="detail.jsp?id=<%=Cayenne.intPKForObject(a)%>"> <%=a.getName()%>
</a></p>
<%
}
T %
<hr>
<p><a href="detail.jsp">Create new artist...</a></p>
</body>
</html>

* Create the artist editor page src/main/webapp/detail. jsp with the following content:

webapp/detail.jsp

@ page language="java" contentType="text/html" %>

@ page import="org.example.cayenne.persistent.*" %>
<%@ page import="org.apache.cayenne.*" %>

@ page import="java.util.*" %>

@ page import="java.text.*" %>

ObjectContext context = BaseContext.getThreadObjectContext();
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String id = request.getParameter("id");

// find artist for id
Artist artist = null;
if(id !'= null && id.trim().length() > @) {
artist = Cayenne.objectForPK(context, Artist.class, Integer.parselnt(id));

}

if("POST".equals(request.getMethod())) {
// if no id is saved in the hidden field, we are dealing with
// create new artist request
if(artist == null) {
artist = context.newObject(Artist.class);

}

// note that in a real application we would so dome validation ...
// here we just hope the input is correct
artist.setName(request.getParameter("name"));
artist.setDateOfBirthString(request.getParameter("date0fBirth"));

context.commitChanges();

response.sendRedirect("index.jsp");

}

if(artist == null) {
// create transient artist for the form response rendering
artist = new Artist();

}

String name = artist.getName() == null ? "" : artist.getName();

String dob = artist.getDateOfBirth() == null

? "" : new SimpleDateFormat("yyyyMMdd").format(artist.getDateOfBirth());

%>
<html>

<head>

<title>Artist Details</title>
</head>
<body>

<h2>Artists Details</h2>
<form name="EditArtist" action="detail.jsp" method="POST">

<input type="hidden" name="id" value="<%= id != null 7 id : "" %" />
<table border="0">
<tr>

<td>Name:</td>
<td><input type="text" name="name" value="<%= name %>"/></td>
</tr>
<tr>
<td>Date of Birth (yyyyMMdd):</td>
<td><input type="text" name="dateOfBirth" value="<%= dob
%$>"/></td>



</tr>
<tr>
<td></td>
<td align="right"><input type="submit" value="Save" /></td>
</tr>
</table>
</form>
</body>
</html>

Running Web Application

To run the web application we’ll use "maven-jetty-plugin”. To activate it, let’s add the following
piece of code to the "pom.xml" file, following the "dependencies" section and save the POM:

pom.xml

<build>
<plugins>
<plugin>
<groupId>org.mortbay.jetty</groupIld>
<artifactId>maven-jetty-plugin</artifactId>
<version>6.1.22</version>
</plugin>
</plugins>
</build>

Also to run the web application we’ll use "maven-jetty-plugin”. To activate it, let’s add the following
piece of code to the pom.xml file, following the "dependencies" section and save the POM:

pom.xml

<build>
<plugins>
<plugin>
<groupld>org.eclipse.jetty</groupld>
<artifactId>jetty-maven-plugin</artifactId>
<version>9.3.14.v20161028</version>
</plugin>
</plugins>
</build>

* Go to "Run > Run Configurations..." menu, select "Maven Build", right click and select "New"

» Make sure you fill "Name", "Base directory" and "Goals" fields as shown on the screenshot:
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Create, manage, and run configurations @

|—_<|> x | }:9' Name: |cayenne—lulorial |
(" type filter text || (] main =i JRE| " Refresh | B Environment | £ C )]
E Apache Tomcat Base directory:
& Eclipse Application | ${workspace_loc: ftutorial} |
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E Generic Server (_ Browse Workspace... ) (_ Browse File System... ) (_ Variables... )
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B HTTP Preview
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v m2 Maven Build "] Resolve Workspace artifacts
m2 cayenne-tutorial
@ 0O5Gi Framework Parameter Name |Value
Juy Task Context Test
¢ XSL Edit...
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Maven Runtime: | Embedded (3.0-SNAPSHOT/0.12.1.20110112-1712) %) (configure... )
4 N Ny

& Apply ) (_ Revert )

Filter matched 16 of 16 items

@ ( cose ) Run)
Z
e —

* Click "Apply" and "Run". On the first execution it may take a few minutes for Jetty plugin to
download all dependencies, but eventually you’ll see the logs like this:
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[INFO] Scanning for projects...

[INFO]

[INFO] -----mmmmmmmmmmm oo oo e
[INFO] Building tutorial 0.0.1-SNAPSHOT

[INFO] ----mmmmmm o m oo oo o e e e

[INFO] Configuring Jetty for project: tutorial

[INFO] Webapp source directory = /.../tutorial/src/main/webapp
[INFO] Reload Mechanic: automatic

[INFO] Classes = /.../tutorial/target/classes

[INFO] Context path = /tutorial

[INFO] Tmp directory = determined at runtime

[INFO] Web defaults = org/mortbay/jetty/webapp/webdefault.xml
[INFO] Web overrides = none

[INFO] web.xml file = /.../tutorial/src/main/webapp/WEB-INF/web.xml
[INFO] Webapp directory = /.../tutorial/src/main/webapp

[INFO] Starting jetty 6.1.22 ...

INFO::jetty-6.1.22

INFO::No Transaction manager found - if your webapp requires one, please configure
one.

INFO::Started SelectChannelConnector@?d.0.0.0:8080

[INFO] Started Jetty Server

* So the Jetty container just started.

* Now go to http://localhost:8080/tutorial/ URL. You should see "No artists found message" in the

28

web browser and the following output in the Eclipse console:


http://localhost:8080/tutorial/

INFO: Loading XML configuration resource from
file:/.../tutorial/target/classes/cayenne-project.xml
INFO: loading user name and password.
INFO: Created connection pool: jdbc:derby:memory:testdb;create=true

Driver class: org.apache.derby.jdbc.EmbeddedDriver

Min. connections in the pool: 1

Max. connections in the pool: 1
INFO: Opening connection: jdbc:derby:memory:testdb;create=true

Login: null

Password: **¥*****
INFO: +++ Connecting: SUCCESS.
INFO: Detected and installed adapter: org.apache.cayenne.dba.derby.DerbyAdapter
INFO: --- transaction started.
INFO: No schema detected, will create mapped tables
INFO: CREATE TABLE GALLERY (ID INTEGER NOT NULL, NAME VARCHAR (200), PRIMARY KEY
(ID))
INFO: CREATE TABLE ARTIST (DATE_OF_BIRTH DATE, ID INTEGER NOT NULL, NAME VARCHAR
(200), PRIMARY KEY (ID))
INFO: CREATE TABLE PAINTING (ARTIST_ID INTEGER, GALLERY_ID INTEGER, ID INTEGER NOT
NULL,

NAME VARCHAR (200), PRIMARY KEY (ID))
INFO: ALTER TABLE PAINTING ADD FOREIGN KEY (ARTIST_ID) REFERENCES ARTIST (ID)
INFO: ALTER TABLE PAINTING ADD FOREIGN KEY (GALLERY_ID) REFERENCES GALLERY (ID)
INFO: CREATE TABLE AUTO_PK_SUPPORT (
TABLE_NAME CHAR(10@) NOT NULL, NEXT_ID BIGINT NOT NULL, PRIMARY

KEY(TABLE_NAME))
INFO: DELETE FROM AUTO_PK_SUPPORT WHERE TABLE_NAME IN ('ARTIST', 'GALLERY',
"PAINTING")
INFO: INSERT INTO AUTO_PK_SUPPORT (TABLE_NAME, NEXT_ID) VALUES ('ARTIST', 200)
INFO: INSERT INTO AUTO_PK_SUPPORT (TABLE_NAME, NEXT_ID) VALUES ('GALLERY', 200)
INFO: INSERT INTO AUTO_PK_SUPPORT (TABLE_NAME, NEXT_ID) VALUES ('PAINTING', 200)
INFO: SELECT t@.DATE_OF_BIRTH, t@.NAME, t0.ID FROM ARTIST t@ ORDER BY t@.NAME -
prepared in 43 ms.
INFO: === returned @ rows. - took 56 ms.
INFO: +++ transaction committed.

* You can click on "Create new artist" link to create artists. Existing artists can be edited by
clicking on their name:
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J e )= () % ) (& ) (B hup://127.0.0.1:8080/tutorial /index.jsp

Artists:

Malevich

Picasso

Create new artist...

You are done with the tutorial!
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